Kodi v19 “Matrix” 搭配Emby食用技巧

最近在追一部老美剧《Under The Dome》,可惜Emby对片源的支援很不友好,在Emby的ios、macos、部分android客户端均无法正常播放。不然是没声音,不然是无法加载,很显然,这是Emby客户端解码的问题。如果ios设备,使用infuse能缓解症状。

我有两只android TV设备,一只是tivo 4k,一只是firestick 4k,在tivo上就能正常播放,firestick就不行,初步估计应该是原生android和二开android的区别。

于是,我想到了Kodi。

说实话,接触Kodi很多年了,但一直没能成为我主力的观影客户端,原因还是体验问题。但几经折腾,这次也发现了Kodi之美。

目前Kodi已是v19版本,版本代号”Matrix”,相比v18,有了一个底层大版本升级,即放弃python2,全面拥抱python3。带来的问题就是很多插件无法正常使用,比如Kodi食用Emby的必备皮肤插件Embuary。那么,如何能在v19上用EmbyCon+Embuary方案顺滑地还原Emby原生体验呢?

如果是android TV,建议先安装v18版本,因为Embuary暂时没有适配v19,我们需要用修改addon.xml中xbmc gui字段的版本号的方式曲线救国,但这种方式并不会主动触发安装各类依赖库的命令,故,先用适配v18的版本安装好,然后再升级到v19,再重新安装修改过的Embuary版本。

如果是macos,直接安装v19即可。

1、安装Kodi v18

下载地址:Kodi v18.9 android(点击下载

2、安装Emby插件库

需要先选择【从zip安装】,安装Emby插件库,点击下载

下载后,你可以拷贝在U盘上插入android盒子,也可以存在NAS上,利用Kodi的Zeroconf浏览器进行安装。

安装完毕后将在【从库安装】里看到【Kodi Emby Addon】

3、安装EmbyCon和Embuary

进入【Kodi Emby Addon】,直接安装就好。

至此v18的Kodi+Emby就安装好了。

此时可以配置好EmbyCon和Embuary,看看是不是已经成功播放。

4、升级Kodi至v19

下载地址:Kodi v19 android(点击下载

升级完打开Kodi时会等待较长时间,因为涉及python版本迁移。

待Kodi成功打开后,重新安装适配v19的Embuary修改版

5、安装适配v19的Embuary修改版

下载地址:Embuary修改版(点击下载

因为在v18时Embuary及各依赖已经成功安装好,故v19修改版安装完并不会有消息提示。

至此,再启用Embuary皮肤,就完成安装了。

 

另外,我发现EmbyCon无法在Caddy反向代理或iptables端口转发加速的中转地址下正常使用,而Emby客户端是可以的。

打完收工!

 

Subscribe
提醒
0 评论
Inline Feedbacks
View all comments